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User guide for calculating FRET using spectral unmixing with the ImageJ plugin ‘FRETTY’ 

 
Author: Ben Corry, The Australian National University. Website: karri.anu.edu.au 
 
Reference: Quantitative Förster resonance energy transfer efficiency measurements using simultaneous 
spectral unmixing of excitation and emission spectra; S Mustafa, J Hannagan, P Rigby, K Pfleger, B 
Corry; Journal of Biomedical Optics, 18, 026024, 2013. Open access online. 
 
Installation 
 
1. Download FRETTY_plugin.jar to the plugins folder of ImageJ (or subfolder thereof) 
2. Newer versions of ImageJ require the Jama plugin to be installed. Please download the Jama jar file 
    directly from here and copy it into the plugins folder of ImageJ (or subfolder thereof) 
3. Restart ImageJ to add FRETTY to the Plugins menu 
 
Fretty 3D deconvolution 
 
This tool is designed to calculate FRET efficiency from a series of microscope images collected with a 
spectral detector and a range of excitation wavelengths using a 3D spectral unmixing algorithm. This 
algorithm allows for bleed through of the donor emission into the acceptor emission channels and direct 
excitation of the acceptor with the donor excitation to be directly accounted for. The concept is similar to 
the 2D algorithm described below, except now instead of each spectrum referring to the emission 
spectrum collected at a particular excitation wavelength, 3D spectra are used which contain the emission 
intensity for a range of both excitation and emission wavelengths. 
 
To collect data you need to collect the emission spectra using a spectral detector for a number of 
excitation wavelengths. The stacks used for analysis are ordered such that all the emission wavelengths 
for one excitation are found in sequence before moving to the next excitation wavelength. For example if 
you had a stack with 40 slices corresponding to 4 excitation wavelengths, the first 10 slices would be the 
emission wavelengths at the first excitation wavelength. The next 10 slices would be the emission 
wavelengths for the second excitation wavelength and so forth. 
 
How to use Fretty 3D deconvolution 
 
Steps 1, 2 and 3 only need to be followed to set up the analysis tool. Once these have been completed 
you can analyse as many samples as you like by following steps 4 and 5 
 
1. Enter the analysis parameters at the top of the interface: 

a) Excitation wavelengths: the number of different excitation 
wavelengths used. The number of emission wavelengths per 
excitation will be automatically determined from the number of 
slices in each stack.  

b) Donor quantum yield: the quantum yield of the donor fluorophore 
c) Acceptor quantum yield: the quantum yield of the acceptor 

fluorophore 
d) Pixel intensity threshold: A FRET image is only created for pixels 

for which at least one slice in the stack has a value above this 
threshold. Not required for ROI FRET analysis 

e) Correct for instrument spectral response: If you wish to correct 
for the different response of the detector to different wavelengths 
then you can tick the check box. Many PMT detectors do not 

http://math.nist.gov/javanumerics/jama/#Package
http://biomedicaloptics.spiedigitallibrary.org/article.aspx?articleid=1654306
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respond linearly to the intensity of incident light, and this may differ at different wavelengths. 
Checking this feature enables a correction to be applied to account for this. 

 
 
 
 
2. Create or load reference spectra 

Red in the spectrum name indicates no spectrum loaded, green indicates spectrum is loaded, 
grey indicates spectrum is not required 

 To create reference spectra: 
a) Load either the data from the donor only sample (for SD) or acceptor only sample (for 

SA) into ImageJ and create a stack ordered as described above.  
For example use File -> Import -> Image sequence in the main ImageJ window 

b) Conduct background reduction.  
To do this, draw background region of interest (ROI) -> press background reduction 
 

c) Create reference spectrum by 
i. Open ROI manager 
ii. For each cell of interest in the image, draw foreground ROI using the tools in the 

main ImageJ window and add to ROI manager using the ‘add’ button 
iii. Press 'create' in the 2D Deconvolution window to make the reference spectrum . 

This adds together the values for all currents ROIs to create a reference 
spectrum.  
  

d) Use optional save and view to store or look at spectrum data. Saving the spectra is very 
useful to expedite the analysis of future FRET images. 
 

Previously saved reference spectra can be loaded using the ‘load’ buttons without having to open 
or indicate stacks 
 

3. Calculate spectral response correction (SRF) (optional) 
This is only necessary if you are trying to normalise the donor and acceptor emission intensities to correct 
for the different repose of the detector to different wavelength as described in step 1. The process works 
by examining all the pixels in an image stack (or set of multiple image stacks) in an image that is 
expected to have the same FRET efficiency throughout. It then works out a numerical correction as a 
function of pixel brightness that will yield the same FRET efficiency for all the pixels. 
 

a) Index from acceptor excitation: this determines whether the pixel brightness is determined from a 
channel with donor excitation or acceptor excitation. We suggest ticking this box if the donor to 
acceptor ratio is known to be the same in the sample used to calculate the SRF as in the FRET 
sample being analysed. If this is not true or not known leaving this blank. 
 

b) Number of intensity bins: choose the number of intensity bins to use in the calculation. This refers 
to the number of bins into which to divide the intensity range in the image. The exact value is not 
critical, but something in the range of 50-100 works well for 16 bit images, a smaller number can 
be used for 8 bit images. If the value is too large you will get a warning when you try to create the 
SRF. In that case we suggest that you reduce the number of intensity bins and try again. 
 

c) Set the wavelength numbers. Wavelength number for donor excitation is used to say which 
excitation wavelength best excites the donor and Wavelength number for acceptor excitation is 
used to say which excitation wavelength best excites the acceptor 
 

d) Load one or more image stacks ordered as described above, corresponding to images that you 
expect to have the same FRET efficiency for all non-background parts of the image. Conduct 
background reduction on each. The more image stacks used here the better the correction 
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function is likely to be as there will be more pixels within each intensity range. 
 

e) Create the spectral response function by pressing the ‘create’ button. The reference spectra must 
have already been loaded before you do this! 
 
 

f) The function can be viewed, or saved for future use. Saving the IRF is very useful to expedite the 
analysis of future FRET images. 
 

g) Previously saved IRF can be loaded using the ‘load’ button without having to load or indicate 
stacks 

 
4. Load images for analysis 

a) Load the data from the mixed sample (FRET sample containing both donor and acceptor) into 
ImageJ and create a stack ordered as described above.  

b) Conduct background reduction. 
c) Make this FRET stack the active window (bring it the front) by clicking on it if it is not already at 

the front 
d) Press ‘Indicate donor acceptor stack’ button to classify this stack 
 

 
5. FRET analysis 
 

To create a FRET image, in which each pixel is replaced by the FRET efficiency value at that 
position, click 'create FRET image' 
 
To calculate the FRET efficiency in a region of interest (ROI) using the average intensities in the 
region, first open the ROI manager, add as many ROIs as you like to the ROI manager, and then 
click 'ROI FRET values'  

 
 
 
 
Example videos are available demonstrating the use of the 3D Deconvolution plugin
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Fretty 2D deconvolution 
 
This tool is designed to calculate FRET efficiency from a series of microscope images collected with a 
spectral detector using a 2D spectral unmixing algorithm. This algorithm allows for bleed through of the 
donor emission into the acceptor emission channels to be directly accounted for, improving the accuracy 
of the FRET calculation. A new image can be created in which each pixel contains the FRET efficiency 
value at that position, or the FRET efficiency can be calculated in a region of interest in the image. The 
direct excitation of the acceptor using the donor excitation wavelength can be corrected for if desired 
using the cross excitation function. 
 
Before using this plugin, consider using the 3Dconvolution plugin. It is easier and accounts for 
cross excitation directly rather than requiring an addition correction. 
 
For this tool to work a few simple guidelines must be followed when collecting the microscope data. 
 

1. Two excitation wavelengths are required, one designed to primarily excite the donor fluorophore 
and one to primarily excite the acceptor. 

2. The emission data should be collected for the same number and range of wavelengths in each 
case 

3. All images, ie for donor only sample, acceptor only sample and mixed sample, should be taken 
with the same microscope settings (eg laser power, detector gain, pinhole etc) 

4. One set of reference spectra can be used for many mixed samples, provided the same 
microscope settings were used for collection 

5. When conducting cross excitation correction  
a. Acceptor only sample should be imaged using both donor and acceptor excitation without 

moving the field of view 
b. The mixed sample (containing both donor and acceptor) should be imaged using both 

donor and acceptor excitation without moving the field of view  
 
How to use Fretty 2D Deconvolution 
 
Steps 1, 2 and 3 only need to be followed to set up the analysis tool. Once 
these have been completed you can analyse as many samples as you like 
by following steps 4 and 5 
 
1. Enter the analysis parameters at the top of the interface: 

a) Cross excitation correction: check this if you want to account for 
direct excitation of the acceptor fluorophores when using donor 
excitation wavelength. Requires additional reference spectrum 
(SAA) and acceptor excitation stack 

b) Use IRF in FRET Calculations: Check this if you want to use an 
‘instrument response function’ (IRF) either when calculating the 
cross excitation correction or calculating FRET efficiency. The IRF 
is necessary is the detector does not respond linearly to the 
intensity of incident light. Experience has shown this may be 
necessary for PMT detectors. 

c) Wavelengths per sample: the number of emission wavelengths in 
each sample, should correspond to the number of images in each 
stack described below. This should be the same for all the 
reference spectra and the excitation stacks 

d) Donor quantum yield: the quantum yield of the donor fluorophore 
e) Acceptor quantum yield: the quantum yield of the acceptor 

fluorophore 
f) Pixel intensity threshold: A FRET image is only created for pixels 

for which at least one slice in the stack has a value above this 
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threshold. Not required for ROI FRET analysis 
 

2. Create or Load the required reference spectra 
Red in the spectrum name indicates no spectrum loaded, green indicates spectrum is loaded, 
grey indicates spectrum is not required 
The spectra refer to those obtained in each of the following cases: 
SDD: Donor only sample with donor excitation 
SAD: Acceptor only sample with donor excitation 
SAA: Acceptor only sample with acceptor excitation. Only required when using cross excitation 
      correction 

 
To create reference spectra follow the steps below: 
 For each reference spectra 

i. Open image stack  (for example use File -> Import -> Image sequence in the main ImageJ 
window) 

ii. Draw background ROI -> press background reduction 
iii. Open ROI manager 
iv. For each cell of interest in the image, draw foreground ROI using the tools in the main ImageJ 

window and add to ROI manager using the ‘add’ button 
v. Press 'create' in the 2D Deconvolution window to make the reference spectrum . This adds 

together the values for all currents ROIs to create a reference spectrum.   
vi. Use optional save and view to store or look at spectrum data. Saving the spectra is very useful to 

expedite the analysis of future FRET images. 
 

Note that SDA and SAA spectra should be created using images of the exact same sample and the 
same ROIs  

 
Previously saved reference spectra can be loaded using the ‘load’ buttons without having to open or 
indicate stacks  

 
3. Create or load instrument response function (IRF) (optional) 

If you want to use the IRF then follow the steps below, otherwise you move directly to step 4 
 
To create an instrument response function: 

a) Choose the number of intensity bins to use in the calculation. This refers to the 
number of bins into which to divide the intensity range in the SAD and SAA 
stacks. The exact value is not critical, but something in the range of 50-100 
works well for 16 bit images. If the value is too large you will get a warning when 
you try to create the IRF. 

b) Make the SAD stack the active window (bring it the front) by clicking on it. This is 
the same stack used for creating the SAD spectrum in step 2 above. 
SAD: Acceptor only sample with donor excitation 
SAA: Acceptor only sample with acceptor excitation.  

c) Press ‘Indicate SAD stack’ button to classify this stack 
d) Make the SAA stack the active window (bring it the front) by clicking on it. This is 

the same stack used for creating the SAA spectrum in step 2 above. 
SAA: Acceptor only sample with acceptor excitation.  

e) Press ‘Indicate SAD stack’ button to classify this stack 
f) Once both stacks have been indicated and the buttons are green, press ‘create’ 

to make an IRF 
g) Use optional save and view to store or look at the IRF data. Saving the IRF is 

very useful to expedite the analysis of future FRET images. 
 

Previously saved IRF can be loaded using the ‘load’ button without having to load or indicate 
stacks 
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If you wish to correct for the spectral response of the detector (for example if the detector 
does not respond the same in the donor and acceptor emission channels) then you can 
tick the check box ‘Normalise D:A intensities with SRF’. In this case you should  
i. Create the SRF using the 3D deconvolution plugin described above  
ii. Tick the checkbox ‘Normalise D:A intensities with SRF’ 
iii. Use the ‘load’ button to load the previously saved SRF. 

 
 
4. Load images for analysis 

a) Load in donor excitation stack (for example use File -> Import -> Image sequence in the main 
ImageJ window) 
 

b) Conduct background reduction (Draw background ROI -> press background reduction) 
 

c) If using cross excitation correction  
a. Load in acceptor excitation stack 
b. conduct background reduction 

 
d) Make donor excitation stack the active window (bring it the front) by clicking on it 
e) Press ‘Indicate donor excitation stack’ button to classify this stack 

 
f) If using cross excitation correction  

a. Make acceptor excitation stack the active window (bring it the front) by clicking on it 
b. Press ‘Indicate acceptor excitation stack’ button to classify this stack 

  
5. FRET analysis 
 

To create a FRET image, in which each pixel is replaced by the FRET efficiency value at that 
position, click 'create FRET image' 
 
To calculate the FRET efficiency in a region of interest using the average intensities in the region, 
click 'ROI FRET values'  

 
Glossary: 
 
Stack: The stacks are always containing a series of images recorded at different emission wavelengths, 
ie from a spectral detector 

Reference spectrum: Spectrum from donor only or acceptor only images, that will be used to analayse 
many FRET samples 

SDD: Reference spectrum from a donor only sample with donor excitation 
SAD: Reference spectrum from an acceptor only sample with donor excitation 
SAA: Reference spectrum from an acceptor only sample with acceptor excitation. Only required when 
using cross excitation correction 
Donor excitation stack: Sample for FRET analysis (ie containing both donor and acceptor) obtained with 
donor excitation 

Acceptor excitation stack: Sample for FRET analysis (ie containing both donor and acceptor) obtained 
with acceptor excitation 

ROI: Region of interest 

Background reduction: Used to remove the background signal. For each slice in the stack, subtracts the 
average intensity value of the current region of interest from all pixels in the image.  




